www.ymjm.net > MyEClipsE中启动tomCAt后出现错误:严重: Error in...

MyEClipsE中启动tomCAt后出现错误:严重: Error in...

说明myeclipse和qqlive不兼容, 如果要用到tomcat服务器的话,那你就只能关闭qqlive了

错误很明显,端口被占用了.很有可能是之前启动的tomcat没被正常结束.解决办法:打开任务管理器,把里面的java.exe,javaw.exe,tomcat.exe(如果有)都结束了.当然有可能把myeclipse也关了,所以操作前先保存好.或者看下端口8005被什么程序占用了

java.net.bindexception: address already in use: jvm_bind:8080 可能其它的应用程序已使用了8080端口

原因:tomcat要开启的端口被占用了!解决办法:如果你用的是8080端口,请按以下方式查找端口被哪个程序占用了:“开始”--“运行”“cmd”“netstat -ano”回车会出现以下结果:C:\Users\candy>netstat -ano 活动连接 协议 本地地址

一看就是找不到方法,我曾经遇到过一次这样的问题,最后我把myeclipse关掉重启了一下,就可以了,是因为myeclipse缓存的影响,导致了类文件中的一个方法没有加载导致的,不知道你的是不是这个原因,如果不是,可以检查一下的类文件中哪里少写了方法,或者方法名写错了,估计是你接口类的问题.

web.xml配置错误,主要看看spring的配置,没加载到spring的监听

错误原因是JDK配置不正确.解决办法:在Eclipse的菜单找到Window-〉Preferences 点击后在弹出窗口的左半部分找到Tomcat,然后在它的子项里找到JVMSetting,点击它,然后在右边的详细内容里吧JRE这个下拉菜单里选上你的JDK版本.OK了.

出现该错误是由于class编译器的jdk版本高于运行期的jdk版本. 比如我在运行tomcat servlet时出现该错误,是由于tomcat运行时是1.6的jdk,eclipse编译时则是1.7 修改方法:保证编译器和运行期的jdk版本一致. eclipse修改: windows window -> preferences->java -> compiler 设置 "compiler compliance level" 为 1.6 (相应版本)

坏了

你把tomcat所在文件件内的webappps内的已部署工程删了后试试,还有tomcat的环境变量检查一下看

相关搜索:

友情链接:clwn.net | acpcw.com | alloyfurniture.com | jinxiaoque.net | lyhk.net | 网站地图

All rights reserved Powered by www.ymjm.net

copyright ©right 2010-2021。
www.ymjm.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com